增加config文件使.NET 4以下的旧程序可以运行

.NET框架4.0上是可以运行为2.0、3.0、3.5设计的应用程序的,但出于兼容性方面的考虑,默认情况下这种功能不会启用。微软的建议是由程序的提供者重新编译,或者增加一个config文件来指示旧程序可以运行在4.0的环境中——不过不建议普通用户这么做。
那么,如何增加这个config文件呢?config文件内容如何写呢?
假设你的程序名字叫做“落伍啦.exe”,复制以下内容到记事本并保存为“落伍啦.exe.config”,放到“落伍啦.exe”所在的文件夹下即可。
<?xml version="1.0"?>
2
<configuration>
3
<startup useLegacyV2RuntimeActivationPolicy="true">
4
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
5
</startup>
6
</configuration>

版权声明:
作者:admin
链接:http://286.la/?p=117
来源:落伍啦
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
< <上一篇
下一篇>>